[Beowulf] Does anyone here mix CISC and RISC within their clusters.

Darren Wise darren at wisecorp.co.uk
Wed Oct 26 22:00:16 PDT 2016

Heya folks,
I have a SUN T2000 SPARC64 quadcore (16 HW threads niagra) using ORACLE Linux 1.0 (don't ask but SOLARIS 10,11 just was not having it.. At all)
Along with seven dual socket, quadcore AMD x86-64 CISC nodes running ubuntu 16.4LTS, MPICH and OpenMPI are giving me some strange errors but as soon as I opt out the SUN box everything runs smoothly.
I know it's not the best idea since sliced bread came about, but if I have the machines around just wanted to add the sun T2k into the mix.
Tried starting processes from both CISC and RISC sides but only when they are seperate do they fully complete.
Shared NFS and passwordless SSH is all installed fine apart from some version number differences and the same with the actual age of the distributions, ORACLE linux SPARC64 edition version 1.0 must be a few years old now circa 2013 maybe verses ubuntu 16.4LTS which must be early on this year and the same with OpenMPI versions differing I gather..
I will try to down and upgrade the packages from source, compile and try to sync all that.Just curious really if anyone else has tried doing this at home or where ever..

> Kind regards,
> Darren Wise Esq, 
> B.Sc, HND, GNVQ, City & Guilds.
> Managing Director (MD)
> Art Director (AD)
> Chief Architect/Analyst (CA/A)
> Chief Technical Officer (CTO)
> www.wisecorp.co.uk> www.wisecorp.co.uk/babywise
> www.darrenwise.co.uk
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.beowulf.org/pipermail/beowulf/attachments/20161027/7ec031dc/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 20161027_053815_resized.jpg
Type: image/jpeg
Size: 3128927 bytes
Desc: not available
URL: <http://www.beowulf.org/pipermail/beowulf/attachments/20161027/7ec031dc/attachment-0001.jpg>

More information about the Beowulf mailing list