[Beowulf] Fwd: warewulf - cannot log into nodes

Duke Nguyen duke.lists at gmx.com
Tue Nov 27 01:37:42 PST 2012

On 11/27/12 2:14 PM, Duke Nguyen wrote:
> On 11/27/12 1:44 PM, Christopher Samuel wrote:
>> Hash: SHA1
>> On 27/11/12 15:51, Duke Nguyen wrote:
>>> Thanks! Yes, I am trying to get the system work with
>>> Torque/Maui/OpenMPI now.
>> Make sure you build Open-MPI with support for Torques TM interface,
>> that will save you a lot of hassle as it means mpiexec/mpirun will
>> find out directly from Torque what nodes and processors have been
>> allocated for the job.
> Christopher, how would I check that? I got Torque/Maui/OpenMPI up,
> working with root (not with normal user yet :( !!!), tried mpirun and it
> worked fine:

Probably not with TM:

# /usr/lib64/openmpi/bin/ompi_info | grep tm

I installed via yum *after* installing torque/maui (also with yum) with 
the hope that openmpi would recognize the presents of torque/maui and 
automatically configure itself to support Torque, but it is apparently 
not like that :). I might have to install from source and configure 
manually with --with-tm I guess.


More information about the Beowulf mailing list