[Beowulf] PXEBoot struggling

Duke Nguyen duke.lists at gmx.com
Mon Nov 26 21:07:23 PST 2012

On 11/20/12 11:07 PM, Lux, Jim (337C) wrote:
> On the other hand, there is some value in thrashing your way through it manually the first time, especially with a small cluster like Duke is putting together.
> I'm a huge fan of automation and tools, in general, but... when it breaks, you have no clue what's wrong.
> You can think of it as a week's worth of lab classes in cluster admin.
> (I went through a similar set of hassles trying to PXEboot a 4 node cluster over a wireless LAN..  It took me two weeks to figure it all out, but, boy, did I know a LOT more about Debian, NFS mounts,  and how the boot process worked after that.  )

Agreed! I recall the first time I tried with a small wifi cluster (one 
desktop and two laptops), it took me like days to set up just the DHCP 
server, and now it took me only a few seconds. I like automation too, 
but I also want all to be in my control :).

> Jim Lux
> -----Original Message-----
> From: beowulf-bounces at beowulf.org [mailto:beowulf-bounces at beowulf.org] On Behalf Of Tru Huynh
> Sent: Monday, November 19, 2012 5:05 AM
> To: Duke Nguyen
> Cc: Beowulf Mailing List
> Subject: Re: [Beowulf] PXEBoot struggling
> On Mon, Nov 19, 2012 at 03:43:48PM +0700, Duke Nguyen wrote:
>> Hi folks,
> ...
>> After few days struggling with the system, here are what I have done:
>>   * install SL6.3 on master node
>>   * install DHCP server (using dhcpd) on master node
>>   * install xinetd and enable tftp
>>   * open firewall for tftp and dhcpd using iptables
> You could ease your way and try warewulf:
> http://hpc.admin-magazine.com/Articles/Warewulf-Cluster-Manager-Master-and-Compute-Nodes
>> So to summarize:
>>   * boot using liveCD -> OK, logging in fine
>>   * boot using rsync of master node's system -> OK, cant log in
> SElinux is probably on the way, did you relabel?
>>   * boot using rsync of client node's sytem -> cant boot
> you need to build/setup the boot from nfs on yur diskless clients.
> - do you have dracut-network installed (required for nfs booting)
> - pass the nfsroot flags to your client
> something like root=nfs:master:/nfsroot/c6 rw
> - fix /etc/fstab for /
> - fix /etc/sysconfig/network-scripts/ifcfg-eth0
> ONBOOT=no # since you already have network
> Cheers,
> Tru

More information about the Beowulf mailing list