[Beowulf] Re: cluster fails to boot with managed switch,but 5-port switch works OK

Hearns, John john.hearns at mclaren.com
Wed Dec 2 10:36:47 PST 2009

I've tried resetting the SMC switch to factory defaults (with
auto-negotiate on).  I've checked the /etc/beowulf/modprobe.conf and it
doesn't seem to be demanding anything exotic.  We've tried swapping out
to another SMC switch but that didn't change anything.  

No idea really, as I don't use SMC switches.
First thing I would do would be to get a laptop with Linux on, and
attach it to the SMC switch.
Configure the Ethernet interface to use DHCP, then ifconfig it down then
ifcoinfig it up.
Run tcpdump eth0 as you do this, and tail -f /var/log/messages

If it gets a DHCP address (and of course on the cluster head node there
is a pool of free DHCP addresses configured)
the test tftp file transfer. Set the tftp daemon on the head node to run
in debug mode, and start it up.
Try a tftp get of a test file on the laptop.

The contents of this email are confidential and for the exclusive use of the intended recipient.  If you receive this email in error you should not copy it, retransmit it, use it or disclose its contents but should return it to the sender immediately and delete your copy.

More information about the Beowulf mailing list