[Beowulf] Simple MPI programs hang

Gregg Germain saville at comcast.net
Wed Mar 19 16:31:21 PDT 2008

Hi everyone,

I've created a 2 node cluster running FC8.  I've installed MPICH2 
1.0.6pl on both (not NFS'd).

The Master, Ragnar, is a 64 bit; olaf is a 32 bit.

I set up the ring, and mpdtrace shows:

$ mpdtrace -l
Ragnar_37601 (
olaf_45530 (

I run a VERY simple MPI program and it hangs:
#include "mpi.h"
#include <stdio.h>
#include <math.h>
#include <string.h>

int main( int argc, char *argv[] )
   return 0;

The program outputs the two lines for the two nodes and hangs. I have to 
CNTRL-C out of it:

[gregg at Ragnar ~/BEOAPPS]$ mpiexec -l -n 2 mpibase
0: Hello!
1: Hello!

It would sit there forever if I didn't bail. Other simple tests work fine:

Running a simple "hostname" test works fine:

$ mpiexec -l -n 2 hostname
0: Ragnar
1: olaf

Now I run a Hello World (no MPI):
#include <stdio.h>
#include <math.h>

int main(int argc,char *argv[])
   printf("\nHello World!\n %d \n", n);

$ mpiexec -l -n 2 ../HelloWorld
0: Hello World!
1: Hello World!

Any help with this would be appreciated


More information about the Beowulf mailing list