[Beowulf] Passwordless ssh - strange problem

laytonjb at charter.net laytonjb at charter.net
Fri Sep 14 10:58:22 PDT 2007

And Reuti wins the prize!!!! The root of the account (.) was 777. I
changed it to 755 (so others can look at it) and now it works!!!
I need to create a nice script that checks all of the things that
everyone has mentioned. I never would have thought to look at

Thanks everyone for your help. It's really nice to see so much help
on the list.



P.S. If you come to SC07, find me and I'll buy you a beer or whatever
you want. If you can't find me, find Doug Eadline (probably in the
Appro booth being a booth bunny and he can find me). This goes
for anyone. If we have the LECCIBG (or however it's spelled, I can
buy there). Maybe we'll also have another Clustermonkey bash.

---- Reuti <reuti at staff.uni-marburg.de> wrote: 
> Hi,
> Am 14.09.2007 um 18:53 schrieb <laytonjb at charter.net>:
> > Afternoon cluster party goers,
> >
> > I'm having trouble on a cluster with passwordless ssh. I followed  
> > all the
> > steps (I think). On the head node, I generated the public and private
> > keys and then copied id_rsa.pub to authorized keys. Then I tried
> > logging into compute nodes and it asks for my password every time
> > (regardless of the number of times I log into the node). I've tried  
> > changing
> > the permissions on authorized_keys a few times (600, 644) and that
> > doesn't seem to change the behavior. Any ideas?
> ssh -v -v -v ...
> might tell you more. The ~/.ssh has permission 600, your home  
> directory is only writable by the user, nor group or other? The ~ is  
> shared to the nodes and /etc/ssh/sshd_config allows public key login  
> on the nodes?
> -- Reuti

More information about the Beowulf mailing list