[Beowulf] Passwordless ssh - strange problem

Robert G. Brown rgb at phy.duke.edu
Fri Sep 14 11:00:11 PDT 2007

On Fri, 14 Sep 2007, laytonjb at charter.net wrote:

> Afternoon cluster party goers,
> I'm having trouble on a cluster with passwordless ssh. I followed all the
> steps (I think). On the head node, I generated the public and private
> keys and then copied id_rsa.pub to authorized keys. Then I tried
> logging into compute nodes and it asks for my password every time
> (regardless of the number of times I log into the node). I've tried changing
> the permissions on authorized_keys a few times (600, 644) and that
> doesn't seem to change the behavior. Any ideas?

   a) Check PAM -- could be screwed up, but unlikely

   b) Kill selinux by shooting it in the head a few times and then
clubbing the corpse until it stops twitching -- quite likely

   c) Always possible that there is some sort of wierdness elsewhere in
your firewall setup or some inherited file or in the permissions
associated with known hosts or... but you know that and I expect you've
checked it all.

I vote for selinux, but wouldn't be surprised if it were pam.


> Thanks!
> Jeff
> _______________________________________________
> Beowulf mailing list, Beowulf at beowulf.org
> To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf

Robert G. Brown	                       http://www.phy.duke.edu/~rgb/
Duke University Dept. of Physics, Box 90305
Durham, N.C. 27708-0305
Phone: 1-919-660-2567  Fax: 919-660-2525     email:rgb at phy.duke.edu

More information about the Beowulf mailing list