[Beowulf] Passwordless ssh - strange problem

Lombard, David N dnlombar at ichips.intel.com
Fri Sep 14 10:33:18 PDT 2007

On Fri, Sep 14, 2007 at 12:53:35PM -0400, laytonjb at charter.net wrote:
> Afternoon cluster party goers,
> I'm having trouble on a cluster with passwordless ssh. I followed all the
> steps (I think). On the head node, I generated the public and private
> keys and then copied id_rsa.pub to authorized keys. Then I tried
> logging into compute nodes and it asks for my password every time
> (regardless of the number of times I log into the node). I've tried changing
> the permissions on authorized_keys a few times (600, 644) and that
> doesn't seem to change the behavior. Any ideas?

ownership and perms on ~/.ssh on both sides?

does remote /etc/ssh/sshd_config preclude keys?
Check PreferredAuthentications

What does ssh -v say?

The agent doesn't need to handle identities w/o passphrases.

David N. Lombard, Intel, Irvine, CA
I do not speak for Intel Corporation; all comments are strictly my own.

More information about the Beowulf mailing list