[Beowulf] /etc/security/limits.conf and Torque jobs

陈齐旺 qiwang.chen at powerleader.com.cn
Thu Nov 23 23:16:48 PST 2006

I just install Rocks v4.2.1 on our IA64 Cluster, I encounterred this problem,
when I used torque 2.1.2, It still get 128k for ulimit -l, and I can't modify the
limit. So I can't use OpenMPI and Intel MPI to run MPI program.

>Just encountered this myself.  Restarting the entire cluster with new limits,
>still get default 32k for ulimit -l when inside torque.  Outside of torque
>everything sees the new limit set in limits.conf.
>Just another data point.  I'm going to keep searching and eventually go to
>the source.
>Dan W.
>On Wed, May 17, 2006 at 06:17:43PM -0400, Mark Hahn wrote:
> > So I submit a job, through Torque, and I simply execute a "ulimit -l" 
> > only to find that my limit is set to the original value, 32.  Using a 
> inherited from the process that started your process, probably.
> try restarting relevant scheduler daemons - it matters when they
> started up relative to your limits.conf changes.
> incidentally what leads you to think you should be using memory locking?
> it's generally a very bad idea, since, like running in RT scheduling 
> priorities, you're preventing the kernel's normal balancing...

More information about the Beowulf mailing list