[Beowulf] Beowulf cluster mpi problem

chandru chandu_dreams2001 at yahoo.co.in
Fri Jan 6 04:04:54 PST 2006

I have built a Linux cluster with a master and a
slave. The communication medium is ssh. ssh works
without any passwords. this has been acheived using
the public keys. I have installed mpich 1.2.7 p1. I am
using Fedora core 2.

when i run a mpi program on the master..

If i run mpirun nwith 1 processor everything works

[root at master basic]# mpirun -np 1 cpi
Process 0 of 1 on master.mydomain.com
pi is approximately 3.1415926544231341, Error is
wall clock time = 0.000634

But if i run it with 2 procesors it gives me this
error message

[root at master basic]# mpirun -np 2 cpi
rm_3771:  p4_error: rm_start: net_conn_to_listener
failed: 32902
p0_4293:  p4_error: Child process exited while making
connection to remote process on client1.mydomain.com:
p0_4293: (10.253768) net_send: could not write to
fd=4, errno = 32
[root at master basic]#

I do not know where the problem is. I have updated the
machines.LINUX file. it has the client's host name
"client1.mydomain.com". SSH connection exists between
master and client. 

Please help 


Yahoo! DSL – Something to write home about. 
Just $16.99/mo. or less. 

More information about the Beowulf mailing list