[Beowulf] OT: PXE boot with no control over DHCP?

David Mathog mathog at mendel.bio.caltech.edu
Thu Sep 22 11:25:04 PDT 2005

On one workstation in the room in question (attached to the same
switch as the PXE workstation) these commands were run:

  /etc/rc.d/init.d/iptables stop
  tcpdump -e -vv >foo.txt

Then I tried a PXE boot on the second workstation.  After it
timed out the log file was searched with:

  grep -i '00:04:76:EF:AF:FA' foo.txt

but it matched no records.  Since that's the ethernet address
of the machine that was trying to PXE boot it would appear that
none of the PXE packets were captured by the second machine.  This
is consistent with the absence of any records in the log file
for my first attempt with my existing DHCP server when service
on the public ethernet interface was enabled.

Note that the ethernet connector on the PXE booting workstation
was live for a long time, it is powered on so that it can respond
to WOL, so presumably the "newly active port delay" mentioned
earlier in this thread should not be the problem.  Just in case
I let the workstation try PXE booting a couple of times
in a row with tcpdump running, and in no case were any packets
seen by the monitoring workstation.

There are still a few more variables, for instance, I've not
tried booting one of these workstations on the internal net
so there could be some bug in the PXE code (seems unlikely...).

Any other ideas?


David Mathog
mathog at caltech.edu
Manager, Sequence Analysis Facility, Biology Division, Caltech

More information about the Beowulf mailing list