[Beowulf] running non-mpi programs on beowulf cluster

billk01 billk01 at metrumrg.com
Wed Feb 16 04:45:48 PST 2005

I have a program that is called from a perl batch script.  The program 
is non-MPI aware so I have been  using mpprun to execute the perl 
program.  The perl program can start from 1 - x processes depending upon 
the arguments to the batch file.  I currently call the batch file as:

mpprun -no-local perl batch.p 1 2 3 &

1 2 3 cause the perl program to start proceses 1 2 and 3 in three 
different directories.  (The different directories are necessary because 
of the nature of the program being run.)  The results is three processes 
all running on one node. (Each node has two processors and there are 3 
nodes for now for a total of 6 processors.)  I have tried supplying the 
-np x  option but this simply starts starts the same three processes 
over an another node once the initial three processes are complete. The 
same thing occurs if I use the -map x:x:x option.  I have also tried 
batching the commant via the "batch now" interactive command line 
interface and the results is the same.
Is there anyway to indicate to the cluster to load balance these 
processes across the nodes?  Or do I need to start each process with a 
seperate mpprun command?  Also, it appears that the NO_LOCAL=1 option 
does not work with the "Batch" command.  Does that seem correct?
The cluster consists of a dual processor (2 Xeon's) master node with 
three compute nodes each with 2 Xeon processors.  Eventually we will 
have a number of additional nodes up but I am testing for now.

Any help would be greatly appreciated.



More information about the Beowulf mailing list