[Beowulf] RE: Beowulf Digest, Vol 16, Issue 35

Cheng, Kevin kc40 at hw.ac.uk
Wed Aug 3 03:43:07 PDT 2005

This concerns passwordless rsh but with the annoying kerberos connection errors:


I just like to tell everybody that at last I found out why my rsh was using Kerberos5 resulting in annoying messages (when am trying to get a clean passwordless rsh). As I analysed from the list:

Connection refused
Trying krb4
Connection refused
Trying normal

The first being a kerberos 5, then a version 4 try before finally a normal being successful. I thought there must be more than one version of rsh installed. So I typed 'locate rsh'. I try the first on the list. I typed '/usr/bin/rsh localhost' and that worked fine. Then typed 'which rsh'. To my surprise it says '/usr/kerberos/bin/rsh'. I then 
looked at my $PATH and see that that's the first folder that's being pathed. So I removed it. Problem solved. 




PS: They should put this in the MPICH-1 Installer guide

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.beowulf.org/pipermail/beowulf/attachments/20050803/678784da/attachment.html>

More information about the Beowulf mailing list