[Beowulf] rlogin works but rsh fails

Joe Landman landman at scalableinformatics.com
Thu Jul 15 19:54:54 PDT 2004

Hi Sandy:

  What does

       which rsh

report?  Or

       env | grep -i rsh


sandeep krishnan wrote:

>Hi ,
>  I have setup a B cluster. I originally had ssh
>working between the guarded clusters. However, I need
>to use rsh to have the processing time lower than that
>caused by ssh. I got the rsh rpm pkg(RH 8.0) and
>installed it on Red Hat 8.0 systems in my cluster. I
>changed the necessary files on each server -
>hosts.allow/deny/equiv + /xinetd.d/rsh-rlogin. Then I
>tried to login from Master to one of the nodes. The
>problem though, was that the connection always
>defaults to ssh rather than using rsh. SO, I disabled
>ssh and tried to connect using rsh from master to node
>and it failed with the command 
>"ssh: connect to address port 22: Connection
>This means that it is still looking for a ssh server
>rather than an rsh server. Furthermore, I can use
>rlogin from Master to Node and I get connected to port
>513 on the Node.  Please could someone help me figure
>out this problem. I found an exact same problem in
>google, however no ANSWER/SOLUTION.  
>Sandeep Krishnan 
>Graduate Student 
>Oklahoma State University
>Do you Yahoo!?
>Yahoo! Mail - 50x more storage than other providers!
>Beowulf mailing list, Beowulf at beowulf.org
>To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf

Joseph Landman, Ph.D
Scalable Informatics LLC,
email: landman at scalableinformatics.com
web  : http://scalableinformatics.com
phone: +1 734 612 4615

More information about the Beowulf mailing list