[Beowulf] mpirun -nolocal option seems no to be working

Mario Leandro Bertogna mlbertog at yahoo.com
Thu Dec 30 07:21:19 PST 2004

Hi, I've 3 sun sparc ultra 10 with suse 7.3, mpich
1.2.6. and ssh v2
Everything works ok if I run this example from machine

#../../bin/mpirun -np 4 cpi
Process 0 of 4 on c02.uncoma.edu.ar
pi is approximately 3.1415926544231239, Error is
wall clock time = 0.015761
Process 1 of 4 on c03.uncoma.edu.ar
Process 2 of 4 on c04.uncoma.edu.ar
Process 3 of 4 on c02.uncoma.edu.ar

But if i want to use -nolocal options, mpi just runs
in one processor, even using -np 4

# ../../bin/mpirun -np 4 -nolocal cpi
Process 0 of 1 on c03.uncoma.edu.ar
pi is approximately 3.1415926544231341, Error is
wall clock time = 0.003563

I tried this, and everything seems to be OK
./mpirun -np 4 -no-local -v -t ../examples/basic/cpi
/usr/local/mpich-1.2.6/bin/../examples/basic/cpi on 4
LINUX ch_p4 processors
Procgroup file:
c03 0 /usr/local/mpich-1.2.6/bin/../examples/basic/cpi
c04 1 /usr/local/mpich-1.2.6/bin/../examples/basic/cpi
c03 1 /usr/local/mpich-1.2.6/bin/../examples/basic/cpi
c04 1 /usr/local/mpich-1.2.6/bin/../examples/basic/cpi
ssh c03 

And I force -p4pg with the procgrout file and gives me
the next error:
./mpirun -p4pg pp.txt ../examples/basic/cpi
rm_20531:  p4_error: rm_start: net_conn_to_listener
failed: 3975
p0_30125:  p4_error: Child process exited while making
connection to remote process on c04: 0
P4 procgroup file is pp.txt.

I just want to run mpi but not in the master node,
someone has an idea what's happening?
Thanks in advance


Do You Yahoo!?
Información de Estados Unidos y América Latina, en Yahoo! Noticias.
Visítanos en http://noticias.espanol.yahoo.com

More information about the Beowulf mailing list