[Beowulf] Raid disk read performance issue in Linux 2.6, anyone seen this?

Craig Tierney ctierney at HPTI.com
Tue Dec 7 11:23:34 PST 2004

On Tue, 2004-12-07 at 06:07, Bogdan Costescu wrote:
> On Mon, 6 Dec 2004, Craig Tierney wrote:
> > an a Opteron dual 1.8 Ghz and an Itanium dual 1.4 Ghz, both running
> > White Box.
> I seriously doubt this. WhiteBox for Itanium ? Since when ? :-)

I meant White Box distribution which is a rebuild of Red Hat Enterprise
3.  It was an early release for Opteron and Itanium.  Since then,
the Gelato Foundation has taken over the rebuilds and should be

Now if you are referring to 'White box' Itanium machines, then I guess
that depends on how you define white box.  I can go buy a non-Intel
Itanium motherboard, CPUs, and memory and build on myself if I so

> > The same physical computer was not used in all tests, or even for
> > the same architecture.
> That's messy. Different devices can behave differently with the same 
> driver on different architectures, due to differences in PCI 
> implementation, cache alignment, etc. I don't say however that this 
> explains the big difference that you saw between 2.4 and 2.6...

True.  However I did do two tests on the same physical hardware.
I ran the White Box Distro based on a 2.4 kernel and Suse 9.1 Profession
based on a 2.6 kernel on an Opteron system. I saw the same behavior.

It isn't exact, but every single 2.6 based system I have tried
has shown this problem.  Every 2.4 based system has not shown this

> > However, since the behavior seems to cross different architectures
> > with different interfaces, I don't think the problem is with an
> > individual server.
> Based on the description so far, I would lean towards file-system
> differences. But you did not specify how you got the speed figures:  
> hdparm, bonnie, zcav, iozone, tiobench, something else ? The main
> question being: at device level or file-system level ?

I primarily used lmdd to test the performance of the filesystem.
All I care about is big streaming IO.  I did try sgpdd which accesses
the device directly and I saw the same behavior.


More information about the Beowulf mailing list