[Beowulf] Raid disk read performance issue in Linux 2.6, anyone seen this?

Craig Tierney ctierney at HPTI.com
Mon Dec 6 08:50:20 PST 2004

On Mon, 2004-12-06 at 09:39, Bogdan Costescu wrote:
> On Sat, 4 Dec 2004, Craig Tierney wrote:
> > This problem appears on different storage.  I have tried DDN (raid 3),
> > Nexsan (raid 5), and Infotrend (raid 3 and 5).
> So the subject is a bit misleading as you are not using software RAID,
> but only connecting a hardware RAID box through SCSI or FC; is this
> right ? If so, what SCSI/FC card and what Linux module are you using ?
> For the 2.4 test, the hardware RAID box was connected to the same 
> computer or to another one ?

All of these solutions are hardware raid.  Two of them (DDN and
Nexsan) were connected by Fibre channel.  The infotrend box
was U320 SCSI.

The FC is QLA2200F (1 Gbit/s) using the vendor driver.  This is
v8.x in the linux-2.6 and v6.x for the linux-2.4 kernel.  The
SCSI was the built-in card on Itanium systems (not sure which
one right now, system is down).

I tried several 2.4 systems and all performed consistently after
tweaking the max_readahead.  I tested a dual P3 with Fedora Core 1
(linux 2.4.26), an a Opteron dual 1.8 Ghz and an Itanium dual 1.4 Ghz,
both running White Box.  When I tested the 2.6 kernel, I tested
SuSE 9.1 Pro on the Opteron and Redhat Enterprise Beta on the Itanium.

The same physical computer was not used in all tests, or even
for the same architecture.  However, since the behavior seems 
to cross different architectures with different interfaces, 
I don't think the problem is with an individual server.


More information about the Beowulf mailing list