i need help... badly

William Gropp gropp at mcs.anl.gov
Wed Sep 18 14:53:47 PDT 2002

At 07:39 PM 9/17/2002 -0700, Mary Francis Moll wrote:
>I ran the tstmachines script but errors occurred.
>Running the true command on each machine went fine but
>when the ls command was run, I get the error that
>~/bin/mpichfoo was not s file or directory. And this
>only occurred for the other machines. At the end of
>the error message, the only machine that seems to be
>available was the machines I ran the script on.
>Please, please, please, I need help...

This means that the machines in your cluster do not have a shared file 
system, for example, they don't use NFS cross mounts to make a common file 
system visible (with the same path name) to each machine in your 
cluster.  The mpirun script relies on having a shared file system, though 
it is possible to run MPICH programs without one.  If you can't setup a 
shared file system, you will need to arrange to copy the executables to 
each machine first, and then use a "procgroup file" (covered in the 
documentation) to specify which executables to run on each machine.


More information about the Beowulf mailing list