mpich ch_p4mpd problem..

Noel Rycroft noel at
Wed Jun 19 08:19:21 PDT 2002

  solved my own problem in the end... simply because Linux
places your host with the locahost ip in /etc/hosts.

Noel Rycroft wrote:

>  Has anyone had success with the ch_p4mpd device...?
> I've got it configured and compiled and have started the daemons on 
> all my boxes
> but cannot even get the simple example/cpi program to run
> when I try and include a remote machine....
> The error is :
> ../bin/mpirun -np 2 -m machines cpi
> Process 0 on boxer
> Process 1 on mille
> p1_13343: (2.019287) p4_peer_msg_handler: failed connect to
> p1_13343:  p4_error: failed to connnect: -1
>   p4_error: latest msg from perror: Connection refused
> I previously had this working for the ch_p4 device. My real problem is 
> that I
> wish to pass environment variables to a program so I've tried using 
> the serv_p4
> and ch_p4 device but sometimes the server wouldn't start... (probably 
> a port no.
> problem).  I can pass the environment variables using the ch_p4mpd device
> but as soon as two machines need to connect it seems to fail...
> any ideas anyone...?
> thanks in advance... Noel.
> ps. configured using gcc3.1 on Linux...
> _______________________________________________
> Beowulf mailing list, Beowulf at <mailto:Beowulf at>
> To change your subscription (digest mode or unsubscribe) visit 

More information about the Beowulf mailing list