NFS-root mounting problem

Bogdan Costescu bogdan.costescu at
Tue Jul 2 04:15:02 PDT 2002

On Mon, 1 Jul 2002, Jakob Oestergaard wrote:

> Ok - I tried many variations on this, to no avail.

Have you tried setting the "noauto" option for the root FS in /etc/fstab ?
IIRC, that's all that I did for a cluster based on RH 7.2, no modification 
in the rc files (of course that means I get an error of not being able to 
run 'fsck.nfs' on each boot).

> One thing that I stumbled across was, that it is always mounted as
> NFSv2, while both client and server support NFSv3.

And "nolock" too, by default. OTOH, I deemed NFSv3 unnecessary for the 
client root FS that I created: it's mostly for reading anyway and there 
are no files larger than 2 GB...

Bogdan Costescu

IWR - Interdisziplinaeres Zentrum fuer Wissenschaftliches Rechnen
Universitaet Heidelberg, INF 368, D-69120 Heidelberg, GERMANY
Telephone: +49 6221 54 8869, Telefax: +49 6221 54 8868
E-mail: Bogdan.Costescu at IWR.Uni-Heidelberg.De

More information about the Beowulf mailing list