Can't format 2nd hard drives on slave nodes in Scyld

Sean Dilda agrajag at
Wed Oct 10 14:20:39 PDT 2001

On Wed, 10 Oct 2001, Tony Stocker wrote:

> I had some problems at first getting the slave nodes to install, but finally 
> got beofdisk to format the primary hdd (/dev/hda) on the slave node.
> However, the slave nodes have a second hdd as well (/dev/hdb) and I can not 
> seem to get beofdisk to do anything to them.  I have created a mapping file 
> hdb:4865:255:63 (I modeled it after the working file for the hda hard drive) 
> in the same location the mapping file for /dev/hda is, but I can't seem to 
> get beofdisk to do anything except fdisk /dev/hda.

Hm.. can you give more details on the exact beofdisk comment that you
typed and what output it gave?

> I have tried using bpsh to manually sfdisk the drive, but after launching 
> the command: `bpsh -n 0 sfdisk /dev/hdb`  all I get is something along the 
> lines of: "Checking to see if anyone is using this disk <CR> OK" and then 
> nothing, it appears to hang.  I've tried redirecting input to the sfdisk 
> command via a file but the same thing occurs.  I've left the process alone 
> for several hours but nothing ever happens.

You should be able to do 'bpsh 0 fdisk /dev/hdb' and do it by hand.
However the best way is with beofdisk and I'd like more information on
that as I said so that we can figure out if there's a problem with it.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 232 bytes
Desc: not available
URL: <>

More information about the Beowulf mailing list