Problem with 3c905-C-TX cards under Scyld

Tony Stocker akostocker at
Thu Oct 4 11:26:46 PDT 2001

Dr. Becker,

Thanks for the advice.  However, folks, I've run into a new snag and I'm 
hoping that someone can help me.

I copied the files necessary to compile the new 3c59x driver to a floppy on 
my workstation (linux).  I then took it to the host node, running Scyld 
(version 27Bz-7 I'm guessing based on Dr. Becker's response) and attempted 
to mount the floppy and copy the files off of it.  I received this error:

mount: /dev/fd0 has wrong major or minor number

I did an ls of /dev/fd0 and the major number is '2' and the minor number is 
'0'.  Then I did an `lsmod` and noticed that I only had one module 
(qlogicfc) loaded.  So I tried to do a `modprobe floppy` and got this error 

modprobe: Can't open dependencies file 
/lib/modules/2.2.17-33.beosmp/modules.dep (No such file or directory)

So I looked around and while the directory exists, the file does not.  I 
used the find command but could not find any file named "modules.dep" on the 
system.  By the way, this same error occurs whenever I attempt to modprobe 

Just for grins I did the following set of commands:
insmod autofs
insmod fat
insmod vfat
insmod floppy  [Error message= insmod: floppy: no module by that name found]
insmod ide-floppy

Then I tried to mount the floppy drive again and got this error:

mount: /dev/fd0 is not a valid block device

I do find it odd that not a single module, beyond the Qlogic Fibre Channel 
module, is loaded.  Not autofs, sound, fat, supermount, isofs, nothing.  I 
guess that the missing modules.dep file accounts for this, but I don't know.

Are these problems I'm having known with my version of the OS?  Is my 
version of Scyld hideously out of date or something?  Did I miss some 
important step during the install?

I appreciate all the help!  Thanks very much!

-Tony Stocker
akostocker at
astocker at

>From: Donald Becker <becker at>
>To: tonystocker at
>CC: beowulf at
>Subject: Re: Problem with 3c905-C-TX cards under Scyld
>Date: Wed, 3 Oct 2001 18:00:52 -0400 (EDT)

>Presumably you are using 27Bz-7, and actually have 3c905CX cards.
>The CX cards were made on a different fab line and have a different
>not-quite-spec transceiver management interface.
>This is fixed with the updated driver in 27*z-8.
>You must first load pci-scan.o.  This is loaded automatically if you use
>'modprobe' instead of 'insmod'.

>A updated driver, or an updated distribution.
>This update applies to 3c905CX cards on all systems, not just Scyld.
>Donald Becker				becker at

Get your FREE download of MSN Explorer at

More information about the Beowulf mailing list