[3c509] DHCP problems under SuSE8.0 but not under SuSE7.1 on 133MHZ box against DI 804

Carsten Kuckuk Carsten Kuckuk <ck@kuckuk.com>
Sat Aug 17 05:33:01 2002

Hello list,

I'm not sure if this is the right list for my question but I'll try it

I have a pretty old Pentium-133 box at home with a 3C509B ISA NIC. A
few weeks ago, I bought a D-Link DI-804 Broadband Gateway / Firewall
Router thingie in order to create a small home network. The DI-804
also offers DHCP services, so it's a pretty nifty thing. Originally I
had SuSE 7.1 installed on it, and everything went fine. DHCP worked,
and I could communicate with my new Athlon-1800 box. Especially the
DHCP part of the system worked well.

Last weekend, I upgraded my Pentium-133 box to SuSE 8.0. To my
surprise, DHCP stopped working. Network functionality is still there,
and I can connect to my other machine using IP numbers. It's just that
DHCP doesn't work.

My first hypothesis was that maybe SuSE 8.0 DHCP is broken (in
connection with DI-804) but that's not the case. I installed SuSE 8.0
on my Athlon-1800 box, and everything worked fine there, especially

My current hypothesis is, that maybe it is a speed or Interrupt
latency problem with my old box, but that should have manifested
itself with SuSE 7.1.

Does anybody on this list have an idea what the reason for this might
be and what I might try?!



Carsten Kuckuk, ck at kuckuk.com | () ascii ribbon campaign
http://www.kuckuk.com/home/ck/   | /\   - against html mail