[3c509] 3c509.c driver won't compile

John Terry johnandkatyterry@home.com
Mon, 5 Mar 2001 06:43:41 -0800


Thanks for your timely and excellent support.  And thanks for writing the
drivers in the first place.
After I read your reply, I tried it and it appears to work, in that the
source code now compiles, but with a couple of warning messages.  After I
get off work tonight I will try to install and test the driver module to
find out whether I will need to upgrade my glibc or not.

After I read your e-mail response, I re-read the stuff on your web site
about Red Hat 7.0 and realized that you had already covered the additional
parameters to add to the compile command, if I had read more carefully in
the first place.

Thanks again

John Terry

----- Original Message -----
From: "Donald Becker" <becker@scyld.com>
To: "John Terry" <johnandkatyterry@home.com>
Cc: <3c509@scyld.com>
Sent: Sunday, March 04, 2001 6:31 AM
Subject: Re: [3c509] 3c509.c driver won't compile

> On Sat, 3 Mar 2001, John Terry wrote:
> > I have a problem with the latest version of the 3c509.c driver source
> > code.  It will not compile for me.  I found it in:
> >
> >  /usr/src/linux-2.2.16/drivers/net
> >
> > and tried to compile it using the compile instructions at the bottom of
the file.  Since I am using Red Hat 7.0 I substituted kgcc in place of gcc,
and used the command:
> >
> > kgcc -DMODULE -D__KERNEL__ -Wall -Wstrict-prototypes -O6 -c 3c509.c
> Add -I/usr/src/linux-2.2.16/include to compile line.
> If this doesn't fix the problem, you must update your glibc package --
> the original Red Hat 7.0 one was bogus.
> Donald Becker becker@scyld.com
> Scyld Computing Corporation http://www.scyld.com
> 410 Severn Ave. Suite 210 Second Generation Beowulf Clusters
> Annapolis MD 21403 410-990-9993