[3c509] redhat 6.2, new kernel 2.2.18, 3c509x.c compiles but....

Curt Howland curt@blue-edge-tech.com
Wed, 11 Apr 2001 12:41:02 +0900

Dell Optiplex with the 3com 3c920 on the motherboard. since the Win2K virus
was installed when it arrived, i had taken down note on the system drivers
and things like that before installing Linux.

it stated "3c905c-tx compatible" so i assume i'm getting the right driver

Redhat 6.2 had the 3c509 driver, and it worked fine. kernel version 2.2.14-5

however, i'm compiling and running the kernel version 2.2.18.

the compile of 3c59x.c (and pci-scan.c) compile without errors, but insmod
gives the follow errors:

# /sbin/insmod 3c59x.o
3c59x.o: Unresolved symbol acpi_wake
3c59x.o: Unresolved symbol acpi_set_pwr_state
3c59x.o: Unresolved symbol pci_drv_unregister
3c59x.o: Unresolved symbol pci_drv_register

i installed it anyway, and tried to boot.

at boot time, the boot messages show the card is detected as a 3c905c, IRQ's
detected, etc.

however, when insmod attempts to load the driver, it fails. i assume that it
is because of the unresolved symbols.

and yes, it is trying to load .../2.2.18/net/3c59x.o  

any clues?


Curt Howland           Senior Network Engineer
curt@blue-edge-tech.com Blue Edge Technologies
+81.3.5472.1349                          Tokyo