[vortex] 3c905b stuck in 10Mbit mode

Brian Densmore bjdensmr@epsi.net
Tue Dec 4 22:05:00 2001

On 04 Dec 2001 15:06:48 +0100, Bogdan Costescu wrote:
> On Mon, 3 Dec 2001, Brian J. Densmore wrote:
> > I used the proper settings. I read all the documentation.
> > with the alias eth0 3c90x I only options 3c90x and valid options for 
> > that driver
> Fine.

I hope I wasn't rude. I was just trying to be clear.

> > Tried that option 4 had no effect, mii-diag -A 100baseTx killed the 
> > card and it stopped talking to the switch, had to come in to the coloc 
> > and reboot.
> It's not clear to me: did you or did you not set the card's EEPROM to 
> autonegotiate for media. If you did, please send the driver start-up 
> messages and outputs from vortex-diag and mii-diag for the situation with 
> no options.

No I haven't tried that yet. I plan one bringing it home and using it
here. I will then be able to
fix off-line.

> > I think you're right it is a board configuration. I will swap it out 
> > with another board I have at home that seems to be working ok.
> Before swapping, it might be better if you check the EEPROM settings of 
> the new card.

I think the other card is fine from reading many of the mii-diag dumps I
have seen on the list.

The problem NIC says this:
  Basic mode control register 0xc000: Auto-negotiation disabled, with
  Speed fixed at 10 mbps, half-duplex.
  Basic mode status register 0xc000 ... c000.
    Link status: not established.

This card reports:
  Basic mode control register 0x3000: Auto-negotiation enabled.
  Basic mode status register 0x7849 ... 7849.
   Link status: not established.

This dump looks more like the ones I see posted in the archive and in
I will try swapping tomorrow. Since my local LAN is hosed for other
reasons now. 
(The one downside to upgrading Linux is all the things you break doing

Thanks for the help.

Brian Densmore