[tulip] Newbie Extreme - problem with Linksys NC100 on Red Hat 7

Liam McCusker radioliam@charter.net
Tue, 3 Apr 2001 08:31:10 -0400

I honestly can't tell you what kernel it is without assuming that the
/usr/src/linux-2.2.16/etc. is the kernel version.  If so, then cool - I can
use that later on.

Anyhow, I tried many different suggestions to install my card.  First tried
to compile the tulip.o file with gcc.  I received all of those errors that
you warn about with Red Hat 7.  After finding your suggestion for this work
around, I tried again with kgcc, but still received errors - or warnings.
There was a compiled driver when I was done, but when I tried to install it
(and kgcc doesn't work with pci-scan.c, had to use gcc) with pci-scan.o, I
still could not detect the card.

I would like to also point out that this machine has two NC100s in it to
start with.  I'm using it as a gateway from WinME (unfortunately).

Any suggestions would be kindly appreciated.  This computer I'm working on
is starting to frustrate me beyond my limits.  :o)


Liam McCusker