Problem w/ NetGear FA310TX Link (Lite-On version) and fix.

Chad Netzer
Tue Dec 29 16:45:31 1998

I was having problems with a couple of Lite-On based cards, and after
some work, I think I've worked the problems out.  Here is a quick
summary of my experiences.

   First I got a LinkSys Etherfast 10/100 PCI Lan card, which didn't
work with my Linux (Redhat 5.1), and after a week of trying various
new drivers and other tricks, I couldn't get it work work reliably
(maybe one out of twenty reboots).  Then, when I installed RH 5.2 w/
the 2.0.36 kernel, it began to work fine (Occasionally it wouldn't
work after a reboot, but another boot would fix that)

   Well, then we got a NetGear FA310tx (Also w/ Lite-On chip) to test,
and it wouldn't work, even on a machine where the Linksys had begun to
work fine.  Hmmmm.  Well after some fiddling, I got it to work
reliably by forcing it to full duplex mode, ie.:

options tulip full_duplex=1

in /etc/conf.modules (or /etc/modules.conf).

However, before I tried this, I tried "options tulip options=12" to
force the media type (This seemed to be a problem w/ the LinkSys
card), and could reliably get this to work if I installed the module
w/ "insmod tulip" but not with "modprobe tulip".  Also, the card would
not work right away, but only after some time doing a netowrk
operation (ie. ping machinename).  Maybe 20 seconds to a minute later,
the pings would start working when I had "insmod" the driver.

Anyway, to make a long story short, I plan to avoid the Lite-On chips
if I can.  Otherwise, people with similar problems may need to force
full duplex, or media type, in order to get them to work on your
network (this was a 10baseT).

PS.  I can never get into the site via ftp or
http (says the host is not found) Has been this way for months (for
me).  Anyone else having the same problem?

Chad Netzer