[eepro100] Re: Intel 815EFV

Alf elvin@elvin.net
Tue, 4 Sep 2001 11:51:57 +0800 (SGT)

Just to update on the situation..

After a long (almost one month) of board replacements, discussions.

Intel recently contacted me to inform me of their Bios patch 13 for the
Intel MicroATX 815EFV motherboards. (Dated 22nd August 2001)

Upon patching, the eepro100 drivers worked without any problems.

Just thought I should let you guys know :)

On Sat, 21 Jul 2001, Alf wrote:

> Date: Sat, 21 Jul 2001 03:18:41 +0800 (SGT)
> From: Alf <elvin@elvin.net>
> To: eepro100@scyld.com, saw@saw.sw.com.sg
> Subject: Intel 815EFV
> Hello,
> 	Some quick background. My company (in Singapore) is developing
> thin client solutions for kiosk-based systems. We were previously using
> the Intel 815EEAL, which is now EOL (End of Line) [This board works 100%
> with no problems with the eepro100 drivers]
> 	We have now obtained the Intel 815EFV (Micro-ATX form factor, the
> normal ATX form factor is coming in this monday or so) which is using the
> same Intel 815E chipset.
> 	The network interface is acting up though. (I've tested the 2.2.19
> kernel eepro100, 2.4.6 eepro100, and the ftp.scyld.com's v1.15 drivers,
> all the *same* results)
> 	When I *first* boot up cold, the network interface will be
> detected, initialized, but not work at all. If I do warm reboot, the
> network interface will be detected, initizliaed and *WORKS*. (Using
> modules, I rmmod, insmod for the cold boot, but it does not work, a reboot
> is needed to make it work)
> 	One observation is that on cold boot and the network interface is
> not working, the output of ifconfig shows 0 RX packets, but many TX
> packets. (I usually use ping to test, when it does not work, i get zero
> replies, and the arp tables are incomplete, RX never increases)
> 	I am working in a 10/100 switched network environment (Tried a
> 10mb hub and another 10/100 switch, no diff)
> 	I noticed this text
> 	"Receiver lock-up bug exists - enablign work-around" for the v1.15
> drivers. (Though the work-around does not seem to work on first bootup)
> 	And for v1.15, the General self-test and Serial sub-system
> self-test will *FAIL* when it's cold booting. (After a reboot, they all
> pass and the network card works) Note that the 2.2.19's v1.09j always
> *PASSES* all the tests.
> 	Note that this happens only on linux. The windows drivers works
> fine on the first boot,etc... *grrr*
> 	My apologies if this mail is long, and thanks in advance to
> whomever can provide me any clues or diagnostic directions.
> Elvin Tan
> -