[eepro100] FYI Intel 82559 and Cisco Catalyst incompatibiliti es

Farrell, Troy troy.farrell@wcg.com
Tue, 7 Aug 2001 10:49:50 -0500

I hope not :)  The manufacturing date is July 1999.  Depending upon your
perspective, that could be ancient or rather modern.


-----Original Message-----
From: Heflin, Roger A. [mailto:Roger.A.Heflin@usa.conoco.com]
Sent: Tuesday, August 07, 2001 10:46 AM
To: 'Farrell, Troy'; 'eepro100@scyld.com'
Subject: RE: [eepro100] FYI Intel 82559 and Cisco Catalyst
incompatibiliti es

The 5500 is a really old piece of hardware.  we had lots of issues with it,
all of the related to both sides figuring out and agreeing on FD/HD and
we had to do alot of forcing of both sides of the connection to get things
otherwise both sides don't seem to agree on the duplex or the 10/100.  I
the 5500 10Mb/100Mb cards came out about the time of the 100Mbit standard on
to figure out half or full duplex and 10/100.  I know our 5500 has a 100mb
card that will
only do 100Mb, and not 10Mb because it predated the standard, and the
card we had was just after the standard (very new implemenation).

The problems we had were with Sun ethernet cards, and the problems are
much like you describe.

On the later model ciscos (2948, 4006, 6509) things seem to be much better,
though we get in trouble there if we force one end without forcing the other
It the 5500 you are using an old piece of hardware? 

> -----Original Message-----
> From:	Farrell, Troy [SMTP:troy.farrell@wcg.com]
> Sent:	 8/ 07/ 2001 10:07 AM
> To:	'eepro100@scyld.com'
> Cc:	'support@penguincomputing.com'
> Subject:	[eepro100] FYI Intel 82559 and Cisco Catalyst
> incompatibilities
> I'm posting this story hoping it will be a help to someone with similar
> problems.
> I've been seeing problems with the onboard adapter on the SuperMicro
> 370-DLR
> MB in my new Penguin Computing Relion 220.  When I plug the Pro/100+ NIC
> into our Cisco Catalyst 5500 with multiple WS-X5225R 24 port 10/100 cards,
> the link light will come on for 30-90 seconds and go off for 5-30 seconds.
> While the problem appears in both DOS and Linux, loading the Intel e100.o
> driver and watching the message log reveals that the card is loosing the
> link.  The driver reports something like "e100: eth0 Link is Down",
> followed
> shortly by "e100: eth0 Link is Up 100FD". The system is running RedHat 7.1
> and I've tried both the 2.4.2RH kernel and a new 2.4.7 kernel with the
> eepro100 and Intel's e100 drivers.  I've also tried Mr. Becker's new
> driver
> at ftp.scyld.com/pub/network/test/eepro100.c .  After reading the eepro100
> list archives, I tried turning off the sleep bit, without any behavior
> change.  To solve this problem, I've put a Linksys 10/100 switch between
> the
> server and the Cisco Catalyst 5500 as the Intel NIC and the Catalyst
> refuse
> to work together.
> The problem is similar to that described by others in the past:
> http://www.scyld.com/pipermail/eepro100/2000-March/000870.html
> http://www.geocrawler.com/archives/3/435/2000/10/0/4468572/
> http://uwsg.iu.edu/hypermail/linux/kernel/0010.2/0904.html
> Troy Farrell
> Video Operations Technician III
> Williams VYVX Services
> Business Media Services
> 918.573.3029
> 918.573.1441 fax
> mailto:troy.farrell@wcg.com
> _______________________________________________
> eepro100 mailing list
> eepro100@scyld.com
> http://www.scyld.com/mailman/listinfo/eepro100