[Beowulf] nVidia Kepler GK110 GPU is incompatible w/Intel x86 hardware in PCI-E 3.0 mode ?

Mikhail Kuzminsky mikky_m at mail.ru
Thu Apr 18 12:19:11 PDT 2013


 I've cluster node (w/Linux, of course) based on Supermicro X9SCA system board and Xeon E3-1230v2 having LGA1155 socket. Now I want to buy GPU nVidia Kepler GK110 w/PCI-E 3.0 (CK20 Compute Board from PNY ?) and install it into my node.  Intel Xeon E3-1230v2 and Supermicro X9SCA both support PCI-E 3.0.

But I've heard that GK110 (available today on the market) can't works in PCI-E v.3.0 mode w/Intel Equipment (only in PCI-E 2.0 mode). But GK104 etc, good for SP only, works w/PCI-E 3.0 normally. Moreover, for successfull work of GK110 w/Intel Xeon Platform I need:
a) to buy next version of Xeon processor which will have new socket (when it'll arrive to the market?)
and new PCI-E 3.0 support plus new system board for this processor (i.e. I need to modernize node hardware)
and b) to buy new GK110 version, which will have improved PCI-E 3.0 interface block (again, when it'll on the market?).

The reason, as I heard, is different realization of PCI-E 3.0 standard  by nVidia and Intel in the corresponding currently available hardware. This is result of poor detalizations of PCI-E 3.0 standard, which should be defined more exactly.

Can somebody clarify this situation ?

Mikhail Kuzminsky
Computer Assistance to Chemical Research Center
Zelinsky Institute of Organic Chemistry RAS
Moscow     




-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.beowulf.org/pipermail/beowulf/attachments/20130418/94defd56/attachment.html 


More information about the Beowulf mailing list