[Beowulf] Problem while booting diskless node.

Maxime Kinet mkinet at ulb.ac.be
Mon Apr 30 03:04:43 PDT 2007


I'm trying to set up my first cluster with diskless nodes. To achieve  
that, I'm using PXElinux on a server, running Fedora Core 6, and a  
NFS-mounted root partition on the node. Everything works perfectly  
(getting the IP address, loading the kernel and mounting the  
filesytem) until the node has to run some binaries located into /sbin  
during the boot process. Apparently it's unable to execute them  
because they have been compiled with dynamically linked libraries and  
not statically. The /sbin directory of the node is a simple copy of  
the one of the server. I tried to avoid the problem using the busybox  
tools, and it worked a bit better but then it couldn't execute bash  
scripts such as rc.sysinit.
As anybody ever encountered such problems and what should I do to  
solve it? recompile the kernel of the node or of the server? change  
the distribution? Are there any other simpler method to proceed than  
using PXE?

Thanks a lot for helping,

Maxime Kinet
Université Libre de Bruxelles
Physique Statistique et Plasmas, CP 231
Campus Plaine - Boulevard du Triomphe,
1050 Bruxelles.

Tel.   : +32-2-650.59.08
e-mail : mkinet at ulb.ac.be

More information about the Beowulf mailing list