[Beowulf] Help with HPL Makefile

snj78 at comcast.net snj78 at comcast.net
Fri Apr 13 14:47:14 PDT 2007


Well, still no luck.  I have done several things but still get the exact same error.  I changed the name of my makefile to Make.Linux_x86_64 to make the arch parameter but that didn't change anything, I am still getting the same error.
I issued the command mpicc -showme and it tells me that I have correctly linked all the openmpi libraries, so that isn't the issue.
When I go to the directory tree /hpl/src/*/Linux_x86_64 where all the make.inc links should be, I can see the actual file Make.inc but double clicking on it in the GUI tells me 
"*/Make.inc does not seem to exist anymore."

I have been running this as root and changed to a user to run this but that didn't help.
Would there be any problems running this as root?

I have also gone into the setups directory and tried to use other makefiles just for kicks, and even with all the parameters completely incorrect, I get the same Makefile:47 error.
This leads me to believe that there is something else that I am overlooking, maybe the fact that this is a 64-bit operating system and I haven't accounted for that?
Doing some more research with this idea, I found a page that explained putting
-xarch=amd64 in the CCNOOPT
field.  Is there some type of flag that I have to use for an Intel Pentium D dual core 64-bit architecture?  I can't seem to think of anything else that could be wrong other than the incompatibility with a 64-bit operating system/architecture.
Thanks again for your help.
Stephen Jenkins

-------------- Original message -------------- 
From: Kilian CAVALOTTI <kilian at stanford.edu> 

> On Wednesday 11 April 2007 09:02:03 pm snj78 at comcast.net wrote: 
> > Thanks for your replies everyone. I feel like I am understanding things 
> > a little better. One thing that I realized but not sure if this makes a 
> > difference is that I have installed an openmpi package and an mpich 
> > package so could that cause problems using the mpicc compiler and 
> > linking the different packages/libraries? 
> 
> If you give the correct pathes in your Makefile, it shouldn't matter. 
> 
> > Makefile:47: Make.inc: No such file or directory 
> > *** No rule to make target 'Make.inc'. Stop 
> 
> Your Make.inc links are likely broken. It may happen if you tried to 
> compile with a wrong TOPdir or arch. 
> Try: 
> find $HOME/hpl -name Make.inc --exec ls -al {} \; 
> 
> to see if the links are indeed broken, and if that's the case: 
> 
> find $HOME/hpl -name Make.inc --exec rm {} \; 
> 
> to remove them. 
> 
> Cheers, 
> -- 
> Kilian 
> _______________________________________________ 
> Beowulf mailing list, Beowulf at beowulf.org 
> To change your subscription (digest mode or unsubscribe) visit 
> http://www.beowulf.org/mailman/listinfo/beowulf 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.scyld.com/pipermail/beowulf/attachments/20070413/6ca9ede7/attachment.html


More information about the Beowulf mailing list