[Beowulf] Node Boot Problem ~ No Keyboard/Harddrive/Diskdrive

Phil Smith pjgsmith at gmail.com
Wed Jun 23 08:12:03 PDT 2004

Hello all,

 I am currently trying to configure a Beowulf cluster and I'm having a
strange problem. The nodes all use PXE and TFTP to acquire the kernel
from the server and then commence booting.

 If the node has a keyboard/hard-drive/floppy-disk-drive plugged into
it, then the system boots perfectly. However, if the node has none of
these devices plugged in, then it crashes (screen goes blank, nic
light goes out). When exactly the node crashes is not consistent,
however it always occurs after the kernel has been transfered and
before the login screen appears.

 I have tried debugging the problem with no success. 

 I first thought that the node was trying to log the 'no keyboard
error' to a local disk, for some reason. But ruled that out when I saw
the problem still occurred when a floppy-drive was present (with no
floppy in the drive).

 I have already tried several different kernels with various settings
(v2.4.20-31.9, v2.4.24, v2.2.26) and the exact same problem remains. I
have stepped through the startup file and found nothing which should
cause such an issue.

The nodes are P4 2.5 Ghz, 512 mb RAM, Intel D845GERG2 motherboards.
There are 64 of them and all of them are diskless. I would rather not
try to resolve this issue by 'buying 64 keyboards'.

Any help/suggestions on resolving this issue would be greatly appreciated.

 -Phil Smith

More information about the Beowulf mailing list