kickstart install using NFS

Yudong Tian yudong at
Wed Oct 9 14:00:56 PDT 2002

Are you using
nfs --dir=/redhat
nfs --server= --dir=/redhat ?
If you are using the former, please consider using the latter

> -----Original Message-----
> From: beowulf-admin at [mailto:beowulf-admin at]On
> Behalf Of Henderson, TL Todd
> Sent: Wednesday, October 09, 2002 3:15 PM
> To: 'beowulf at'
> Subject: kickstart install using NFS
> I'm preparing to install a large number of new nodes using redhat and have
> planned on using the kickstart option.  I have gotten a kickstart
> file setup
> just the way I want it with one exception and I can not get it to work.  I
> ultimately want to boot from a floppy and in the kickstart file tell it to
> get the rpm's from a nfs mount.
> So far I have:
> 1.)  Booted from a cd and issued the command:
> linux ks=floppy
> This is how I built and debugged my ks file.  This gives me what I want,
> except I get to swap CD's during the install.  No nfs option at
> this point.
> 2.)  I added the line
> nfs --dir=/redhat
> and tried the 'linux ks=floppy' again booting from the CD.  It
> continues to
> get the rpms from the CD.
> 3.)  I built a floppy from mkbootdisk, with the ks.cfg file and
> at the boot:
> prompt typed linux ks=floppy.  This time it went directly to the
> resuce boot
> from the HD.
> 4.)  I then got a recommendation from someone to modify the syslinux.cfg
> file on the floppy.  I tried that and got errors like the following:
> mount: error 22 mounting ext2
> pviotroot: .{stuff deleted} failed: 2
> ...
> Kernel panic: No init found.  Try passing init= ...
> 5.)  I've built the system with the CD and my kickstart and made sure I
> could mount my nfs box and directory once everything was up and I could.
> I've given just about everyone premission to the directory and the export.
> I've looked through all the kickstart how-to's, the redhat references and
> can't find anything wrong.
> Here is the relevant part of the ks file:
> install
> lang en_US
> langsupport --default en_US.iso885915 en_US.iso885915
> keyboard us
> mouse generic3ps/2 --device psaux
> skipx
> rootpw --iscrypted blahblahblah
> firewall --disabled
> authconfig --enableshadow --enablemd5
> timezone America/Chicago
> network --bootproto dhcp
> nfs --dir=/redhat/RedHat
> bootloader --location=mbr
> clearpart --all
> zerombr yes
> part / --fstype ext3 --size 5120
> part /home --fstype ext3 --size 1024
> part swap --size 1024
> part /scratch --fstype ext3 --size 1024 --grow
> The directory tree on the remote machine is:
> /redhat
> '-- RedHat
>     |-- RPMS
>     '-- base
> Are the ks commands echo'd to a file so I can see what is happening, or if
> there are any errors?  I've looked at the anaconda-ks.cfg file and it is a
> very close replica of my ks.cfg file, with the glaring exception
> of the nfs
> command, and some post install stuff.
> Thanks in advance for any and all help or suggestions.
> Todd
> _______________________________________________
> Beowulf mailing list, Beowulf at
> To change your subscription (digest mode or unsubscribe) visit

More information about the Beowulf mailing list