Tyan serial console - how?

Robert G. Brown rgb at phy.duke.edu
Tue Nov 5 13:03:44 PST 2002

On Tue, 5 Nov 2002, David Mathog wrote:

> I've been trying to get the Tyan serial console working
> on our rack full of 2466 boards. So far only partial success.
> I've tried this:
> In the BIOS in the serial console section on node A set to:
> on Board ComA, direct, 115200, none, vt100, on
> In kermit on node B (linux) which will connect to A:
> set line /dev/ttyS0
> set speed 115200
> set flow none
> set watch-carrier off
> connect

You also need to select ansi terminal mode in minicom, and vt100 (as you
have) in the bios.  Don't ask me why.  Otherwise you get the console but
e.g. boxes are funny looking with the wrong characters.

> Connect Com A of node A to Com A of node B with a null modem
> cable (6ft).
> Boot node A.
> Node A comes up, there's a quick flash in the kermit window,
> and it goes on to lilo/linux.  On the monitor also plugged into it
> I can see that the quick flash corresponds to the first screen
> of the boot sequence.  It was possible to get into BIOS setup by
> tapping F2 continuously on  node A's keyboard from reset or
> power up.  (By the time anything shows up on A's monitor it's
> always too late to hit F2 :-(.)  I've tried hitting the "F2" key
> in node B's kermit window, but the boot process ignores that and
> goes right on to lilo and linux.

You have a couple of problems here.  One is (and again, it's a major
"grrr" for me as well) you pretty much have to have a real keyboard
plugged into the system when working in the bios to e.g. catch the bios.
In fact, there are a whole bunch of things for which you need the real
keyboard -- it is also impossible to soft reboot (if you try you'll
reboot your laptop/console system, obviously) and one cannot enter the
magic string to enter the PXE bios and configure it.

Hitting F2 in the serial console actually usually does work, but you do
have to have time to get there.  One way to arrange it is to configure
the bios the hard way (using the regular keyboard) so that it does a
memory test at startup.  This takes forever, so you have plenty of time
to press F2.  Unfortunately, you'd probably like to be able to interrupt
the memory check as well, and this only works by pressing escape at a
real keyboard, not the serial console.  Also be sure to turn off halt at
keyboard error in the bios, maybe.

Note that YMMV tremendously here depending on your BIOS revision and
probably your hardware snapshot as well.  For example, some bios
revisions hang if you set ignore keyboard error.  Some hang if you
don't.  None of them that I've tried come up with the serial console
enabled by default, so when you reflash you have to have a video card
and keyboard handy to reset the system in serial console mode.  In all
of our systems, they do the memory test long and slow regardless of what
we set for quickboot or tests (interruptable only with an external
keyboard).  Finally, the systems tend to hang into a mode that can only
be recovered from by power cycling, sometimes by power cycling by
pulling the plug physically and counting to tweny or thirty, arbitrarily

He says with a Grrr, sitting beside his stack laptop in hand, trying to
get the damn things to pxe-ks-reinstall (something that proceeds
trivially for anything else we have).  The 2466's are one of the least
expensive ways to get compute cycles out there, but they tend to cost
US, at least, a lot more in human time than they every should.

> What must be typed in the serial console to break into the BIOS?
> Once in the bios there are squares (single letter size "pixels")
> dancing around the screen like "snow" on a TV.  Presumably the
> serial line protocol isn't set up quite right.  What should it
> have been?

Possibly the ANSI setting, if you're using minicom.  Otherwise, there is
a visible trace (perhaps less annoying) because the serial console on
the systems redraws the screen continuously.  It doesn't seem to use any
absolute character location commands, "vt100" or not.

> Is it possible to use the serial console to break into a 
> Tyan node which has locked up in linux?  By this, I mean
> something similar to the Sun console or the VMS console,
> where you can get in "underneath" the OS and force a
> reboot without having to cycle the power or hit the reset switch.

Not that I've found.  In fact, without an external keyboard or shell
access, one cannot even soft-boot the system at all.  I cycle power on
them in a heartbeat, usually by pulling the plug as it is more certain
to put the system into a consistent initial state.


> Thanks,
> David Mathog
> mathog at caltech.edu
> Manager, Sequence Analysis Facility, Biology Division, Caltech
> _______________________________________________
> Beowulf mailing list, Beowulf at beowulf.org
> To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf

Robert G. Brown	                       http://www.phy.duke.edu/~rgb/
Duke University Dept. of Physics, Box 90305
Durham, N.C. 27708-0305
Phone: 1-919-660-2567  Fax: 919-660-2525     email:rgb at phy.duke.edu

More information about the Beowulf mailing list