DP83820 Chip Set

Luis E. Marquez P. marquezl at cecalc.ula.ve
Wed Mar 20 14:04:36 PST 2002


    I have bought some MB-3792G. This has three network adapter cards on

two dual 10/100 MB ethernet and one Giga bit ethernet.

I have installed the linux kernel 2.4.18, the drivers for the two dual
10/100 MB ethernet cards work fine, but

the driver for the dp83820 giga ethernet from national semiconductors,
doesn't work. I read a faq that I found

on the internet and visited some internet sites, but the problem still

    I have tested the drivers from scyld.org, cdrom drivers that shipped
with the motherboard and the driver

recognized by the 2.4.18 linux kernel.

   I have a dp83820 d-link. When compiling the kernel 2.4.18 with the
support of the dp83820, it works very fine.

    When loading the module ns820.o (scyld.org driver) I get these

Using  /lib/modules/2.4.2-2/kernel/drivers/net/ns820

This is the message I get when i run the lsmod

Module                  Size  Used by
nls_iso8859-1           2880   1  (autoclean)
nls_cp437               4384   1  (autoclean)
vfat                    9392   1  (autoclean)
fat                    32672   0  (autoclean) [vfat]
appletalk              19664   0  (autoclean)
ipx                    15520   0  (autoclean)
ns820                  11216   1  (autoclean)
pci-scan                3152   0  (autoclean) [ns820]
autofs                 11264   1  (autoclean)
eepro100               16624   2  (autoclean)
ipchains               38976   0  (unused)
usb-uhci               20720   0  (unused)
usbcore                49664   1  [usb-uhci]
3w-xxxx                24848   4
sd_mod                 11680   4
scsi_mod               95072   2  [3w-xxxx sd_mod]

This is the message I get when i run ifconfig

ifconfig eth2
eth2      Link encap:Ethernet  HWaddr 00:34:56:16:00:73
          inet addr:  Bcast:  Mask:

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          Interrupt:12 Base address:0x5000

Any idea...?
Thanks in advance...!

      Luis E.  Marquez P.
   Administrador de Sistema

_/  _/  _/      _/_/_/         E-Mail: marquezl at cecalc.ula.ve
_/  _/  _/      _/  _/         http://www.cecalc.ula.ve/~marquezl
_/  _/  _/      _/_/_/
_/_/_/  _/_/_/  _/  _/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.beowulf.org/pipermail/beowulf/attachments/20020320/0a813682/attachment.html>

More information about the Beowulf mailing list