Donald Becker becker at
Sun Aug 11 21:16:26 PDT 2002

On Sat, 10 Aug 2002, Art Edwards wrote:

> This is for SCYLD users (anyone out there?) I'm using the BZ-7 release
> that appears to have an absolutely ancient BASH (it won't recognize
> arrays.)

The 27bz-7 release is from early last year, so it's slightly dated.  The
bash version was current as of the release, so it's hardly ancient.

> So I'm looking to simply install the newest rpm for BASH.

I don't recalled when we switched to bash ver. 2.  The only modification
to the earlier version was to support large files (our release were the
first, or among the first, distribution to have LFS support).  We
switched to bash v2 as soon as it was stable so that were were not
distributing a modified package.

> calculations) to do too many stupid sthings. I have similar questions
> about g77-3.1 and GCC-3.1 . Will installation of these break any of
> the Scyld libraries for, for example, mpif77?

The GCC C languate update shouldn't cause a problem.  I don't know for
certain that the Fortran update is library compatible, but it should be.

Donald Becker				becker at
Scyld Computing Corporation
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993

More information about the Beowulf mailing list