Kickstart Installation problems

Mallik Vonteddu mallik at
Mon Feb 5 11:43:19 PST 2001

Hi Robert

You are right. Something has changed i.e some one had 
plugged his linux test machine on the same network,
which is also running DHCP leasing different IP addresses
on the network. After removing the test box, installation
went on smoothly. 

Thanks a lot for your help

-----Original Message-----
From: Robert G. Brown [mailto:rgb at]
Sent: Sunday, February 04, 2001 6:47 AM
To: Mallik Vonteddu
Cc: 'beowulf at'
Subject: Re: Kickstart Installation problems

On Wed, 31 Jan 2001, Mallik Vonteddu wrote:

> After booting from the floppy, it could able to get the IP address from
> the DHCP server,but it fails to mount the NFS partition.
> It comes out with an error message" Mount: RPC timeout " .
> Checked the following daemons Portmapper,nfsd,mountd and rpcinfo.
> Executing the command "exportfs" shows the exported partitions too.
> Evertyhing seems to work on the nfs server, but when it tries to mount
> the nfs partition, it hangs there for some time and comes out
> as " Mount : RPC timeout " .

Have you checked to make sure that the ip number you are granting still
has permissions to mount?

Have you tried booting a rescue floppy and mounting the NFS partition by

Is the NFS partition mountable by other clients in the net (if they are
given permission to mount)?

I'm sorry if these suggestions sound lame, but you've already checked a
lot, it sounds like, and it worked and now it doesn't.  Either something
changed or something broke (hardware or software).  First hypothesis is
that something changed, so look for something that changed -- an extra
character that somehow got typed in the kickstart line in its dhcpd
entry, an address from the wrong block -- typos can be killers because
everything "works" but -- doesn't.  Second hypothesis is software, so
make sure that the NFS client-server connection is valid for the
exported space for some other reliable client.  Check to be sure that
your kickstart floppy is valid, unbroken, current, and works for some
other client (if you can).  At this point, you've checked the entire
install path, and you're down to client hardware.  Which does break,
although I wouldn't expect it to produce an RPC error (only) if it did.


Robert G. Brown	             
Duke University Dept. of Physics, Box 90305
Durham, N.C. 27708-0305
Phone: 1-919-660-2567  Fax: 919-660-2525     email:rgb at

More information about the Beowulf mailing list