ssh madness

Robert G. Brown rgb at
Thu Jul 13 10:39:17 PDT 2000

On Thu, 13 Jul 2000, Peter Jay Salzman wrote:

> dear all,
> on the front end, we compiled the following in tarball form:
>     ssh-1.2.27/
>     ssh-2.0.13/
> and on the nodes, we installed the following rpms:
>     [p at n01]$ rpm -qa | grep ssh
>     ssh-1.2.27-1
>     ssh-server-1.2.27-1
>     ssh2-2.0.13-1i
> and the two sets of ssh packages are definitely not happy with each other.
> ssh2 doesn't seem to work (ssh2 == ssh):
>    [root at wulfgar ssh]# ssh2 -l p n01
>    Disconnected; protocol version not supported (Illegal protocol version.).
> but ssh1 seems to work fine.
>    [root at wulfgar ssh]# ssh1 -l p n01
>    p at n01's password:
> i need help.  can someone tell me why ssh2 is complaining about illegal
> protocol version?  it looks like both machines should have ssh 2.0.13.

I wish I could help, in part because I've encountered the same problem
and never did solve it.  My solution was to fall back to the 1.2.27
version everywhere.  Another thing that is reputed to work is to use the
OpenSSH product, which seems to be less broken and more backward
compatible than the 2.0.x line.


> much thanks!
> pete
> _______________________________________________
> Beowulf mailing list
> Beowulf at

Robert G. Brown	             
Duke University Dept. of Physics, Box 90305
Durham, N.C. 27708-0305
Phone: 1-919-660-2567  Fax: 919-660-2525     email:rgb at

More information about the Beowulf mailing list