Hamachi Gb ethernet drivers under 2.2 kernel?!

Keith Underwood keithu at parl.clemson.edu
Wed Jul 12 08:50:20 PDT 2000

Um, it's directly under your nose ;-)  The hamachi driver has been updated
and included in 2.2.16.  Don't try to build it into the kernel though.  I
was the last one to work on that code and I never tried that ;-)  The
current incarnation should work better than the previous version, though I
make no guarantee that it still works under the 2.0 series.  I haven't had
time to port to 2.4 either...


On Wed, 12 Jul 2000, Steven Timm wrote:

> I know this is slightly off-topic but seeing that we found the
> initial information on a page that is giving resources for Beowulf
> clusters, maybe someone knows where the updated version is.
> We have a couple of Packet Engines "Hamachi" GB ethernet cards for the
> head nodes
> of our cluster.  They worked OK under 2.0 kernels with a driver
> that was available on the web.  But there doesn't seem to be any 2.2
> or greater kernel support out there.  Has anyone made this work?  Kernel
> upgrade wasn't optional for us.  On the node in question we are running RH
> 6.2 kernel 2.2.16-3smp.

Keith Underwood                   Parallel Architecture Research Lab (PARL)
keithu at parl.clemson.edu                                  Clemson University

More information about the Beowulf mailing list